Java何以查看JSP和Servlet版本

大家在java
web开发的经过中,有时在资料上大概会涉嫌环境所要帮衬的JSP,Servlet版本。假设版本低就只怕出现测试错误。

主意:打开tomcat的common/lib 目录下,有三个JA科雷傲文件: jsp-api.jar
servlet-api.jar
。借使没有,那或许是你未曾增加进去。解压那八个公文,用记事本分别打开META-INF下的MAINMEFT.MF文件。

我的Servlet版本是:Manifest-Version: 1.0
Ant-Version: Apache Ant 1.6.5
Created-By: 1.4.2_12-b03 (Sun Microsystems Inc.)

Name: javax/servlet/
Specification-Title: Java API for Servlets
Specification-Version: 2.4
Java,Specification-Vendor: Sun Microsystems, Inc.
Implementation-Title: javax.servlet
Implementation-Version: 2.4.public_draft
Implementation-Vendor: Apache Software Foundation

我的JSP版本是:Manifest-Version: 1.0
Ant-Version: Apache Ant 1.6.5
Created-By: 1.4.2_12-b03 (Sun Microsystems Inc.)

Name: javax/servlet/jsp/
Specification-Title: Java API for JavaServer Pages
Specification-Version: 2.0
Specification-Vendor: Sun Microsystems, Inc.
Implementation-Title: javax.servlet.jsp
Implementation-Version: 2.0.public_draft
Implementation-Vendor: Apache Software Foundation

初稿地址:http://blog.csdn.net/ma1kong/article/details/5118832

相关文章